{"id":343058,"date":"2022-12-23T15:00:43","date_gmt":"2022-12-23T15:00:43","guid":{"rendered":"http:\/\/savepearlharbor.com\/?p=343058"},"modified":"-0001-11-30T00:00:00","modified_gmt":"2022-12-23T15:00:43","slug":"","status":"publish","type":"post","link":"https:\/\/savepearlharbor.com\/?p=343058","title":{"rendered":"<span>OSPFv2: \u043f\u0435\u0442\u043b\u0438 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438 \u0431\u0435\u0437 \u0440\u0435\u0433\u0438\u0441\u0442\u0440\u0430\u0446\u0438\u0438 \u0438 \u0441\u043c\u0441<\/span>"},"content":{"rendered":"<div><\/div>\n<div id=\"post-content-body\">\n<div>\n<div class=\"article-formatted-body article-formatted-body article-formatted-body_version-2\">\n<div xmlns=\"http:\/\/www.w3.org\/1999\/xhtml\">\n<p>\u041d\u0435 \u0442\u0430\u043a \u0434\u0430\u0432\u043d\u043e \u044f \u0440\u0430\u0441\u0441\u043a\u0430\u0437\u0430\u043b \u043f\u0440\u043e <a href=\"https:\/\/habr.com\/ru\/post\/700380\/\" rel=\"noopener noreferrer nofollow\">\u043e\u0434\u043d\u0443 \u0438\u0437 \u043f\u0440\u0438\u0447\u0438\u043d<\/a> \u043f\u043e\u044f\u0432\u043b\u0435\u043d\u0438\u044f <a href=\"https:\/\/datatracker.ietf.org\/doc\/html\/rfc2328\" rel=\"noopener noreferrer nofollow\">RFC 2328<\/a> \u043d\u0430 \u0441\u043c\u0435\u043d\u0443 <a href=\"https:\/\/datatracker.ietf.org\/doc\/html\/rfc1583\" rel=\"noopener noreferrer nofollow\">RFC 1583<\/a>. \u0412\u043f\u0440\u043e\u0447\u0435\u043c, \u043e\u043f\u0438\u0441\u0430\u043d\u043d\u044b\u0439 \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0439 \u0432\u043e\u0437\u043d\u0438\u043a\u043d\u043e\u0432\u0435\u043d\u0438\u044f \u043f\u0435\u0442\u043b\u0438 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438 \u0441\u043e\u0432\u0441\u0435\u043c \u043d\u0435 \u0435\u0434\u0438\u043d\u0441\u0442\u0432\u0435\u043d\u043d\u044b\u0439. \u0422\u0435 \u0438\u0437 \u0432\u0430\u0441, \u043a\u0442\u043e \u043f\u043e\u0441\u043c\u043e\u0442\u0440\u0435\u043b \u043d\u0430 <a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2178#appendix-G.7\" rel=\"noopener noreferrer nofollow\">RFC 2178<\/a>, \u0441\u043a\u043e\u0440\u0435\u0435 \u0432\u0441\u0435\u0433\u043e, \u0443\u0436\u0435 \u0434\u043e\u0433\u0430\u0434\u044b\u0432\u0430\u044e\u0442\u0441\u044f, \u043e \u0447\u0435\u043c \u043f\u043e\u0439\u0434\u0451\u0442 \u0440\u0435\u0447\u044c \u0434\u0430\u043b\u044c\u0448\u0435.<\/p>\n<p>\u041f\u043e\u043c\u0438\u043c\u043e \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0430\u0433\u0440\u0435\u0433\u0438\u0440\u043e\u0432\u0430\u043d\u043d\u044b\u0445 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u043e\u0432, RFC 2328 \u0442\u0430\u043a\u0436\u0435 \u0438\u0437\u043c\u0435\u043d\u0438\u043b \u043f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430 \u0434\u043b\u044f \u0432\u043d\u0435\u0448\u043d\u0438\u0445 \u043f\u0440\u0435\u0444\u0438\u043a\u0441\u043e\u0432.<\/p>\n<blockquote>\n<p><em>Otherwise, compare the cost of this new AS external path to the ones present in the table.  Type 1 external paths are always shorter than type 2 external paths.  Type 1 external paths are compared by looking at the sum of the distance to the forwarding address and the advertised type 1 metric (X+Y).  Type 2 external paths are compared by looking at the  advertised type 2 metrics, and then if necessary, the distance to the forwarding addresses.<\/em><\/p>\n<p>RFC 1583, <a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc1583#page-154\" rel=\"noopener noreferrer nofollow\">section 16.4<\/a><\/p>\n<\/blockquote>\n<blockquote>\n<p><em>Compare the AS external path described by the LSA with the existing paths in N&#8217;s routing table entry, as follows. If the new path is preferred, it replaces the present paths in N&#8217;s routing table entry.  If the new path is of equal preference, it is added to N&#8217;s routing table entry&#8217;s list of paths.<\/em><\/p>\n<p><em>(a) Intra-area and inter-area paths are always preferred over AS external paths.<\/em><\/p>\n<p><em>(b) Type 1 external paths are always preferred over type 2 external paths. When all paths are type 2 external paths, the paths with the smallest advertised type 2 metric are always preferred.<\/em><\/p>\n<p><em>(c) If the new AS external path is still indistinguishable from the current paths in the N&#8217;s routing table entry, and RFC1583Compatibility is set to &#171;disabled&#187;, select the preferred paths based on the intra-AS paths to the ASBR\/forwarding addresses, as specified in Section 16.4.1.<\/em><\/p>\n<p><em>(d) If the new AS external path is still indistinguishable from the current paths in the N&#8217;s routing table entry, select the preferred path based on a least cost comparison.  Type 1 external paths are compared by looking at the sum of the distance to the forwarding address and the advertised type 1 metric (X+Y).  Type 2 external paths advertising equal type 2 metrics are compared by looking at the distance to the forwarding addresses.<\/em><\/p>\n<p><em>RFC 2328, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2328.html#page-174\" rel=\"noopener noreferrer nofollow\"><em>section 16.4<\/em><\/a><\/p>\n<\/blockquote>\n<blockquote>\n<p>1. <em>Intra-area paths using non-backbone areas are always the most preferred.<br \/>2. The other paths, intra-area backbone paths and inter-area paths, are of equal preference.<\/em><\/p>\n<p><em>RFC 2328, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2328.html#page-175\" rel=\"noopener noreferrer nofollow\"><em>section 16.4.1<\/em><\/a><\/p>\n<\/blockquote>\n<p>\u0412\u043c\u0435\u0441\u0442\u043e \u043f\u0440\u044f\u043c\u043e\u0433\u043e \u043f\u0435\u0440\u0435\u0432\u043e\u0434\u0430 \u044f \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0443 \u043e\u0431\u043e\u0431\u0449\u0438\u0442\u044c \u0441\u0443\u0442\u044c \u0440\u0430\u0437\u043b\u0438\u0447\u0438\u0439:  <\/p>\n<ol>\n<li>\n<p>RFC 1583 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u043e\u0434\u0438\u043d\u0430\u043a\u043e\u0432\u044b\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u044b \u043e\u0442 \u0440\u0430\u0437\u043d\u044b\u0445 ASBR \u0441\u0443\u0433\u0443\u0431\u043e \u043f\u043e \u043c\u0435\u0442\u0440\u0438\u043a\u0435.<\/p>\n<\/li>\n<li>\n<p>RFC 2328, \u0432 \u0441\u0432\u043e\u044e \u043e\u0447\u0435\u0440\u0435\u0434\u044c, \u043e\u0442\u0434\u0430\u0451\u0442 \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0435\u043d\u0438\u0435 ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0449\u0438\u043c\u0441\u044f \u0432\u043d\u0443\u0442\u0440\u0438 \u0442\u043e\u0439 \u0436\u0435 \u043d\u0435\u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b; \u0435\u0441\u043b\u0438 \u0441\u0434\u0435\u043b\u0430\u0442\u044c \u0432\u044b\u0431\u043e\u0440 \u0432\u0441\u0451 \u0435\u0449\u0451 \u043d\u0435 \u0443\u0434\u0430\u043b\u043e\u0441\u044c, \u0442\u043e\u0433\u0434\u0430 OSPF \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0434\u043e ASBR \u0442\u0430\u043a \u0436\u0435, \u043a\u0430\u043a \u0438 RFC 1583.<\/p>\n<\/li>\n<\/ol>\n<p>\u041f\u043e\u043b\u0443\u0447\u0430\u0435\u0442\u0441\u044f, \u0447\u0442\u043e \u043d\u0430\u0441 \u0438\u043d\u0442\u0435\u0440\u0435\u0441\u0443\u044e\u0442 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0438\u0435 \u044d\u043b\u0435\u043c\u0435\u043d\u0442\u044b \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430:<\/p>\n<ol>\n<li>\n<p>\u043f\u0440\u0438\u043e\u0440\u0438\u0442\u0435\u0442 ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0449\u0438\u0445\u0441\u044f \u0432 \u0442\u043e\u0439 \u0436\u0435 \u043d\u0435\u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u0435;<\/p>\n<\/li>\n<li>\n<p>\u0440\u0430\u0432\u0435\u043d\u0441\u0442\u0432\u043e ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0448\u0438\u0445\u0441\u044f \u0432 \u0437\u043e\u043d\u0435 0, \u0438 ASBR \u0438\u0437 \u0434\u0440\u0443\u0433\u0438\u0445 \u0437\u043e\u043d.<\/p>\n<\/li>\n<\/ol>\n<p>\u0420\u0430\u0441\u0441\u043c\u043e\u0442\u0440\u0438\u043c \u043f\u0440\u043e\u0441\u0442\u043e\u0439 \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0439:<\/p>\n<figure class=\"full-width\"><img loading=\"lazy\" decoding=\"async\" src=\"https:\/\/habrastorage.org\/r\/w1560\/getpro\/habr\/upload_files\/e21\/9fd\/a75\/e219fda75ab6daa4e3368b76ea6a047f.png\" width=\"775\" height=\"437\" data-src=\"https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/e21\/9fd\/a75\/e219fda75ab6daa4e3368b76ea6a047f.png\"\/><figcaption><\/figcaption><\/figure>\n<p>ASBR \u043e\u0431\u043c\u0435\u043d\u0438\u0432\u0430\u044e\u0442\u0441\u044f \u043d\u0435\u0441\u043a\u043e\u043b\u044c\u043a\u0438\u043c\u0438 \u043f\u0440\u0435\u0444\u0438\u043a\u0441\u0430\u043c\u0438 \u0441 \u0443\u0437\u043b\u043e\u043c BGP: \u043f\u043e\u043b\u0443\u0447\u0430\u044e\u0442 1.1.1.1\/32 \u0438 \u0430\u043d\u043e\u043d\u0441\u0438\u0440\u0443\u044e\u0442 3.3.3.3\/32. \u041f\u043e\u043c\u0438\u043c\u043e \u044d\u0442\u043e\u0433\u043e, ASBR \u043e\u0431\u044a\u044f\u0432\u043b\u044f\u044e\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442 \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u0432 OSPF \u0434\u043e\u043c\u0435\u043d. \u0414\u0432\u0430 \u0441\u043e\u0435\u0434\u0438\u043d\u0435\u043d\u0438\u044f \u0438\u043c\u0435\u044e\u0442 \u043d\u0435\u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u043d\u044b\u0439 \u0432\u0435\u0441, \u0438\u0445 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u044f \u043e\u0442\u043c\u0435\u0447\u0435\u043d\u044b \u043a\u0440\u0430\u0441\u043d\u044b\u043c \u0446\u0432\u0435\u0442\u043e\u043c. \u041e\u0441\u0442\u0430\u043b\u044c\u043d\u0430\u044f \u043d\u0430\u0441\u0442\u0440\u043e\u0439\u043a\u0430 \u043d\u0435 \u043f\u0440\u0435\u0434\u0441\u0442\u0430\u0432\u043b\u044f\u0435\u0442 \u0441\u0443\u0449\u0435\u0441\u0442\u0432\u0435\u043d\u043d\u043e\u0433\u043e \u0438\u043d\u0442\u0435\u0440\u0435\u0441\u0430, \u0432\u0441\u0435 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u044f \u043e\u0441\u0442\u0430\u0432\u043b\u0435\u043d\u044b \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u2013 \u0442\u043e\u043b\u044c\u043a\u043e \u043b\u043e\u0432\u043a\u043e\u0441\u0442\u044c \u0440\u0443\u043a \u0438 \u043d\u0438\u043a\u0430\u043a\u043e\u0439 \u043c\u0430\u0433\u0438\u0438.<\/p>\n<pre><code>BGP#sho run | section interface|router interface Loopback0  ip address 1.1.1.1 255.255.255.255 interface FastEthernet0\/0  ip address 192.168.16.1 255.255.255.0 interface FastEthernet0\/1  ip address 192.168.12.1 255.255.255.0 router bgp 1  no bgp default ipv4-unicast  neighbor 192.168.12.2 remote-as 100  neighbor 192.168.16.6 remote-as 100  !  address-family ipv4   network 1.1.1.1 mask 255.255.255.255   neighbor 192.168.12.2 activate   neighbor 192.168.16.6 activate<\/code><\/pre>\n<pre><code>ASBR1#sho run | s interface|router interface Loopback0  ip address 2.2.2.2 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.23.2 255.255.255.0  ip ospf 1 area 0  ip ospf cost 10 interface FastEthernet0\/1  ip address 192.168.12.2 255.255.255.0 router ospf 1  default-information originate always router bgp 100  no bgp default ipv4-unicast  neighbor 192.168.12.1 remote-as 1  !  address-family ipv4   network 3.3.3.3 mask 255.255.255.255   neighbor 192.168.12.1 activate<\/code><\/pre>\n<pre><code>ASBR2#sho run | section interface|router interface Loopback0  ip address 6.6.6.6 255.255.255.255  ip ospf 1 area 1 interface FastEthernet0\/0  ip address 192.168.16.6 255.255.255.0 interface FastEthernet0\/1  ip address 192.168.56.6 255.255.255.0  ip ospf 1 area 1 interface FastEthernet1\/0  ip address 192.168.46.6 255.255.255.0  ip ospf 1 area 1  ip ospf cost 100 router ospf 1  default-information originate always router bgp 100  no bgp default ipv4-unicast  neighbor 192.168.16.1 remote-as 1  !  address-family ipv4   network 3.3.3.3 mask 255.255.255.255   neighbor 192.168.16.1 activate<\/code><\/pre>\n<pre><code>ABR1#sho run | section interface|router interface Loopback0  ip address 4.4.4.4 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.45.4 255.255.255.0  ip ospf 1 area 0 interface FastEthernet0\/1  ip address 192.168.34.4 255.255.255.0  ip ospf 1 area 0 interface FastEthernet1\/0  ip address 192.168.46.4 255.255.255.0  ip ospf 1 area 1  ip ospf cost 100 router ospf 1<\/code><\/pre>\n<pre><code>ABR2#sho run | section interface|router interface Loopback0  ip address 5.5.5.5 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.45.5 255.255.255.0  ip ospf 1 area 0 interface FastEthernet0\/1  ip address 192.168.56.5 255.255.255.0  ip ospf 1 area 1 router ospf 1<\/code><\/pre>\n<pre><code>R#sho run | section interface|router interface Loopback0  ip address 3.3.3.3 255.255.255.255 interface FastEthernet0\/0  ip address 192.168.23.3 255.255.255.0  ip ospf cost 10 interface FastEthernet0\/1  ip address 192.168.34.3 255.255.255.0 router ospf 1  network 0.0.0.0 255.255.255.255 area 0<\/code><\/pre>\n<p>\u041c\u043e\u0436\u0435\u0442 \u043f\u043e\u043a\u0430\u0437\u0430\u0442\u044c\u0441\u044f, \u0447\u0442\u043e \u043f\u0440\u0438 \u0442\u0430\u043a\u043e\u0439 \u043d\u0435\u0432\u0438\u043d\u043d\u043e\u0439 \u043d\u0430\u0441\u0442\u0440\u043e\u0439\u043a\u0435 \u0443\u0437\u0435\u043b BGP \u0434\u043e\u043b\u0436\u0435\u043d \u0438\u043c\u0435\u0442\u044c \u0441\u0432\u044f\u0437\u043d\u043e\u0441\u0442\u044c \u0434\u043e 3.3.3.3\/32, \u0443\u0441\u0442\u0430\u043d\u0430\u0432\u043b\u0438\u0432\u0430\u044f \u0441\u043e\u0435\u0434\u0438\u043d\u0435\u043d\u0438\u0435 \u0441 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u043d\u0438\u0435\u043c 1.1.1.1\/32 \u0432 \u043a\u0430\u0447\u0435\u0441\u0442\u0432\u0430 \u0430\u0434\u0440\u0435\u0441\u0430 \u0438\u0441\u0442\u043e\u0447\u043d\u0438\u043a\u0430.<\/p>\n<pre><code>BGP#ping 3.3.3.3 so lo 0 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: Packet sent with a source address of 1.1.1.1  ..... Success rate is 0 percent (0\/5)<\/code><\/pre>\n<p>\u0427\u0442\u043e, \u0432\u043f\u0440\u043e\u0447\u0435\u043c, \u0441\u043e\u0432\u0435\u0440\u0448\u0435\u043d\u043d\u043e \u043d\u0435 \u043c\u0435\u0448\u0430\u0435\u0442 \u0441\u0435\u0442\u0438 \u0434\u043e\u0431\u0440\u043e\u0441\u043e\u0432\u0435\u0441\u0442\u043d\u043e \u0442\u0435\u0440\u044f\u0442\u044c \u0442\u0440\u0430\u0444\u0438\u043a. \u041c\u043e\u0436\u0435\u0442 \u0431\u044b\u0442\u044c, \u0433\u0434\u0435-\u0442\u043e \u043f\u043e \u043f\u0443\u0442\u0438 \u043d\u0435 \u0445\u0432\u0430\u0442\u0430\u0435\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u043e\u0432?<\/p>\n<pre><code>BGP#traceroute 3.3.3.3 source 1.1.1.1 Type escape sequence to abort. Tracing the route to 3.3.3.3 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.16.6 12 msec 24 msec 20 msec   2 192.168.56.5 56 msec 16 msec 36 msec   3  *  *  *  &lt;output omitted><\/code><\/pre>\n<p>\u041f\u043e\u0445\u043e\u0436\u0435 \u043d\u0430 \u0442\u043e, \u0447\u0442\u043e ABR1 \u043e\u0442\u0431\u0440\u0430\u0441\u044b\u0432\u0430\u0435\u0442 \u043f\u0440\u0438\u0445\u043e\u0434\u044f\u0449\u0438\u0435 \u043a \u043d\u0435\u043c\u0443 \u043f\u0430\u043a\u0435\u0442\u044b. \u041e\u0434\u043d\u0430\u043a\u043e \u043f\u0435\u0440\u0432\u043e\u0435 \u0432\u043f\u0435\u0447\u0430\u0442\u043b\u0435\u043d\u0438\u0435 \u043e\u0431\u043c\u0430\u043d\u0447\u0438\u0432\u043e, \u043e\u0441\u043e\u0431\u0435\u043d\u043d\u043e \u0435\u0441\u043b\u0438 \u0437\u0430\u043f\u0443\u0441\u0442\u0438\u0442\u044c traceroute \u0441 \u0434\u0440\u0443\u0433\u043e\u0439 \u0441\u0442\u043e\u0440\u043e\u043d\u044b:<\/p>\n<pre><code>R#traceroute 1.1.1.1 source 3.3.3.3 Type escape sequence to abort. Tracing the route to 1.1.1.1 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.34.4 16 msec 16 msec 20 msec   2 192.168.34.3 20 msec 24 msec 16 msec   3 192.168.34.4 32 msec 36 msec 40 msec   4 192.168.34.3 36 msec 40 msec 36 msec &lt;\u043d\u0443 \u0432\u044b \u043f\u043e\u043d\u044f\u043b\u0438><\/code><\/pre>\n<figure class=\"full-width\"><img loading=\"lazy\" decoding=\"async\" src=\"https:\/\/habrastorage.org\/r\/w780q1\/getpro\/habr\/upload_files\/725\/7a6\/cee\/7257a6cee800df32a68d365941a7293e.jpg\" width=\"1276\" height=\"691\" data-src=\"https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/725\/7a6\/cee\/7257a6cee800df32a68d365941a7293e.jpg\" data-blurred=\"true\"\/><figcaption><\/figcaption><\/figure>\n<p>\u0415\u0441\u043b\u0438 \u043f\u043e\u0441\u043c\u043e\u0442\u0440\u0435\u0442\u044c \u043d\u0430 \u0441\u0445\u0435\u043c\u0443, \u0442\u043e \u0432\u044b\u0431\u043e\u0440 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430 \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u0432 \u0441\u0442\u043e\u0440\u043e\u043d\u0443 ASBR2 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u043e\u043c R \u0432\u044b\u0433\u043b\u044f\u0434\u0438\u0442 \u0440\u0430\u0437\u0443\u043c\u043d\u044b\u043c:  <\/p>\n<pre><code>R#sho ip ospf border-routers                  OSPF Router with ID (3.3.3.3) (Process ID 1)   Base Topology (MTID 0)  Internal Router Routing Table Codes: i - Intra-area route, I - Inter-area route  i 4.4.4.4 [1] via 192.168.34.4, FastEthernet0\/1, ABR, Area 0, SPF 12 i 5.5.5.5 [2] via 192.168.34.4, FastEthernet0\/1, ABR, Area 0, SPF 12 i 2.2.2.2 [10] via 192.168.23.2, FastEthernet0\/0, ASBR, Area 0, SPF 12 I 6.6.6.6 [3] via 192.168.34.4, FastEthernet0\/1, ASBR, Area 0, SPF 12 I 6.6.6.6 [101] via 192.168.34.4, FastEthernet0\/1, ASBR, Area 0, SPF 12<\/code><\/pre>\n<p>\u0410 \u0432\u043e\u0442 ABR1 \u0432\u0435\u0434\u0451\u0442 \u0441\u0435\u0431\u044f \u043d\u0435\u0441\u043a\u043e\u043b\u044c\u043a\u043e \u0441\u0442\u0440\u0430\u043d\u043d\u043e, \u043f\u043e \u043a\u0440\u0430\u0439\u043d\u0435\u0439 \u043c\u0435\u0440\u0435 \u043d\u0430 \u043f\u0435\u0440\u0432\u044b\u0439 \u0432\u0437\u0433\u043b\u044f\u0434:<\/p>\n<pre><code>ABR1#sho ip ospf border-routers               OSPF Router with ID (4.4.4.4) (Process ID 1)   Base Topology (MTID 0)  Internal Router Routing Table Codes: i - Intra-area route, I - Inter-area route  i 5.5.5.5 [101] via 192.168.46.6, FastEthernet1\/0, ABR, Area 1, SPF 8 i 5.5.5.5 [1] via 192.168.45.5, FastEthernet0\/0, ABR, Area 0, SPF 9 i 2.2.2.2 [11] via 192.168.34.3, FastEthernet0\/1, ASBR, Area 0, SPF 9 i 6.6.6.6 [100] via 192.168.46.6, FastEthernet1\/0, ASBR, Area 1, SPF 8<\/code><\/pre>\n<p>\u041e\u0431\u0440\u0430\u0442\u0438\u0442\u0435 \u043f\u0440\u0438\u0441\u0442\u0430\u043b\u044c\u043d\u043e\u0435 \u0432\u043d\u0438\u043c\u0430\u043d\u0438\u0435 \u043d\u0430 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u0435 \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0434\u043e ASBR2 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u043e\u0431\u043e\u0438\u0445 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u043e\u0432. R \u0432\u044b\u0431\u0438\u0440\u0430\u0435\u0442 \u043f\u0443\u0442\u044c \u0447\u0435\u0440\u0435\u0437 ABR2 \u0441 \u0432\u0435\u0441\u043e\u043c, \u0440\u0430\u0432\u043d\u044b\u043c 3; \u0432 \u0441\u0432\u043e\u044e \u043e\u0447\u0435\u0440\u0435\u0434\u044c, ABR1 \u043d\u0435 \u0438\u043c\u0435\u0435\u0442 \u043d\u0438 \u043c\u0430\u043b\u0435\u0439\u0448\u0435\u0433\u043e \u043f\u0440\u0435\u0434\u0441\u0442\u0430\u0432\u043b\u0435\u043d\u0438\u044f \u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0435 \u0447\u0435\u0440\u0435\u0437 ABR2 \u0438 \u0432\u0438\u0434\u0438\u0442 \u0442\u043e\u043b\u044c\u043a\u043e \u043f\u0443\u0442\u044c \u0441 \u0432\u0435\u0441\u043e\u043c, \u0440\u0430\u0432\u043d\u044b\u043c 101. \u041f\u0440\u0438\u0447\u0438\u043d\u0430 \u0442\u0430\u043a\u043e\u0433\u043e \u043f\u043e\u0432\u0435\u0434\u0435\u043d\u0438\u044f \u043f\u0440\u043e\u0437\u0430\u0438\u0447\u043d\u0430: ASBR2 \u0438 ABR1 \u043d\u0430\u0445\u043e\u0434\u044f\u0442\u0441\u044f \u0432 \u043e\u0434\u043d\u043e\u0439 \u0437\u043e\u043d\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 ABR1 \u043e\u0431\u044f\u0437\u0430\u043d \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u0442\u044c \u0432\u043d\u0443\u0442\u0440\u0438\u0437\u043e\u043d\u0430\u043b\u044c\u043d\u044b\u0439 \u043c\u0430\u0440\u0448\u0440\u0443\u0442. \u041a\u0430\u043a \u0441\u043b\u0435\u0434\u0441\u0442\u0432\u0438\u0435, \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0438\u0442\u0435\u043b\u044c\u043d\u043e\u0441\u0442\u044c ASBR \u0432 \u043e\u0447\u0435\u0440\u0435\u0434\u043d\u043e\u0439 \u0440\u0430\u0437 \u043c\u0435\u043d\u044f\u0435\u0442\u0441\u044f \u043f\u043e \u043f\u0443\u0442\u0438 \u0441\u043b\u0435\u0434\u043e\u0432\u0430\u043d\u0438\u044f \u043f\u0430\u043a\u0435\u0442\u0430, \u0447\u0442\u043e \u0438 \u043f\u0440\u0438\u0432\u043e\u0434\u0438\u0442 \u043a \u043f\u0435\u0442\u043b\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438.<\/p>\n<p>\u041f\u0435\u0440\u0435\u043a\u043b\u044e\u0447\u0438\u043c \u0432\u0441\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u044b \u0434\u043e\u043c\u0435\u043d\u0430 \u0432 \u0440\u0435\u0436\u0438\u043c \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0441 RFC 2328:<\/p>\n<pre><code>R(config)#router ospf 1 R(config-router)#no compatible rfc1583<\/code><\/pre>\n<pre><code>R#traceroute 1.1.1.1 so 3.3.3.3 Type escape sequence to abort. Tracing the route to 1.1.1.1 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.34.4 20 msec 32 msec 12 msec   2 192.168.46.6 12 msec 20 msec 8 msec   3 192.168.16.1 4 msec 28 msec 16 msec<\/code><\/pre>\n<pre><code>ABR1#sho ip ro os                               &lt;output omitted> Gateway of last resort is 192.168.46.6 to network 0.0.0.0  O*E2  0.0.0.0\/0 [110\/1] via 192.168.46.6, 00:02:00, FastEthernet0\/1 &lt;output omitted><\/code><\/pre>\n<p>\u041d\u0435\u0441\u043c\u043e\u0442\u0440\u044f \u043d\u0430 \u0442\u043e, \u0447\u0442\u043e \u043d\u0430\u043c \u0443\u0434\u0430\u043b\u043e\u0441\u044c \u043f\u043e\u0431\u043e\u0440\u043e\u0442\u044c \u043f\u0435\u0442\u043b\u044e, \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u044f \u0441\u0442\u0430\u043b\u0430 \u043d\u0435\u043e\u043f\u0442\u0438\u043c\u0430\u043b\u044c\u043d\u043e\u0439. R \u0441\u0447\u0438\u0442\u0430\u0435\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u044b \u0434\u043e ASBR1 (\u0432\u043d\u0443\u0442\u0440\u0438 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b) \u0438 ASBR2 (\u043c\u0435\u0436\u0437\u043e\u043d\u0430\u043b\u044c\u043d\u044b\u0439) \u0440\u0430\u0432\u043d\u043e\u0446\u0435\u043d\u043d\u044b\u043c\u0438, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u0438\u0445 \u0442\u043e\u043b\u044c\u043a\u043e \u043f\u043e \u043c\u0435\u0442\u0440\u0438\u043a\u0435. \u041d\u0435 \u043b\u0443\u0447\u0448\u0435 \u043b\u0438 \u0431\u044b\u043b\u043e \u043e\u0442\u0434\u0430\u0442\u044c \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0435\u043d\u0438\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0443 \u0432\u043d\u0443\u0442\u0440\u0438 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b? \u0418\u043c\u0435\u043d\u043d\u043e \u0442\u0430\u043a \u0438 \u0434\u0443\u043c\u0430\u043b\u0438 \u0430\u0432\u0442\u043e\u0440\u044b RFC 2178:<\/p>\n<blockquote>\n<p><em>1. Intra-area paths using non-backbone areas are always the most preferred.<br \/>2. Otherwise, intra-area backbone paths are preferred.<br \/>3. Inter-area paths are the least preferred.<\/em><\/p>\n<p><em>RFC 2178, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2178.html#section-16.4.1\" rel=\"noopener noreferrer nofollow\"><em>section 16.4.1<\/em><\/a><\/p>\n<\/blockquote>\n<p>\u0412\u043f\u0440\u043e\u0447\u0435\u043c, \u043d\u0430\u0448\u043b\u0430\u0441\u044c \u0432\u0435\u0441\u043e\u043c\u0430\u044f \u043f\u0440\u0438\u0447\u0438\u043d\u0430 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u0442\u044c \u0442\u0435\u043a\u0443\u0449\u0438\u0439 \u043f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430:<\/p>\n<blockquote>\n<p><em>There is still the possibility of a routing loop in RFC 2178 when both <\/em> <\/p>\n<p><em>1. virtual links are in use and<br \/>2. the same external route is being imported by multiple ASBRs, each of which is in a separate area. <\/em> <\/p>\n<p><em>To fix this problem, Section 16.4.1 has been revised. To choose the correct ASBR\/forwarding address, intra-area paths through non-backbone areas are always preferred. However, intra-area paths through the backbone area (Area 0) and inter-area paths are now of equal preference, and must be compared solely based on cost.<\/em><\/p>\n<p><em>The reasoning behind this change is as follows. When virtual links are in use, an intra-area backbone path for one router can turn into an inter-area path in a router several hops closer to the destination. Hence, intra-area backbone paths and inter-area paths must be of equal preference. We can safely compare their costs, preferring the path with the smallest cost, due to the calculations in Section 16.3.<\/em><\/p>\n<p><em>RFC 2328, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2328.html#page-241\" rel=\"noopener noreferrer nofollow\"><em>section G.2<\/em><\/a><\/p>\n<\/blockquote>\n<p>\u041d\u0430\u0441\u043a\u043e\u043b\u044c\u043a\u043e \u043c\u043d\u0435 \u0438\u0437\u0432\u0435\u0441\u0442\u043d\u043e, \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0439 OSPF \u0432 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0438\u0438 \u0441 RFC 2178 \u0432 \u043f\u0440\u0438\u0440\u043e\u0434\u0435 \u043d\u0435 \u0441\u0443\u0449\u0435\u0441\u0442\u0432\u0443\u0435\u0442. \u0422\u0443\u0442 \u043d\u0430 \u043f\u043e\u043c\u043e\u0449\u044c \u043c\u043e\u0436\u0435\u0442 \u043f\u0440\u0438\u0439\u0442\u0438 \u0431\u043e\u0433\u0430\u0442\u043e\u0435 \u0432\u043e\u043e\u0431\u0440\u0430\u0436\u0435\u043d\u0438\u0435. \u0420\u0430\u0441\u0441\u043c\u043e\u0442\u0440\u0438\u043c \u0442\u0430\u043a\u0443\u044e \u0441\u0445\u0435\u043c\u0443:<\/p>\n<figure class=\"full-width\"><img loading=\"lazy\" decoding=\"async\" src=\"https:\/\/habrastorage.org\/r\/w1560\/getpro\/habr\/upload_files\/f09\/c3e\/2be\/f09c3e2beb1af7a597ecfa0dc3b69ea4.png\" width=\"939\" height=\"792\" data-src=\"https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/f09\/c3e\/2be\/f09c3e2beb1af7a597ecfa0dc3b69ea4.png\"\/><figcaption><\/figcaption><\/figure>\n<p> \u041f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043f\u043e RFC 2178:<\/p>\n<ol>\n<li>\n<p> R1 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 ASBR1 \u0438\u0437 \u0434\u0440\u0443\u0433\u043e\u0439 \u0437\u043e\u043d\u044b \u0441 ASBR2 \u0432 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u0435 (\u0447\u0435\u0440\u0435\u0437 virtual-link).<\/p>\n<\/li>\n<li>\n<p> ASBR2 \u0432 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u0435 \u043b\u0443\u0447\u0448\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 R1 \u0448\u043b\u0451\u0442 \u043f\u0430\u043a\u0435\u0442 \u0435\u043c\u0443.<\/p>\n<\/li>\n<li>\n<p> R2 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 ASBR1 \u0438 ASBR2, \u043a\u0430\u0436\u0434\u044b\u0439 \u0438\u0437 \u043a\u043e\u0442\u043e\u0440\u044b\u0445 \u043d\u0430\u0445\u043e\u0434\u0438\u0442\u0441\u044f \u0432 \u0434\u0440\u0443\u0433\u043e\u0439 \u0437\u043e\u043d\u0435.<\/p>\n<\/li>\n<li>\n<p> ASBR1 \u0431\u043b\u0438\u0436\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 R2 \u043e\u0442\u043f\u0440\u0430\u0432\u043b\u044f\u0435\u0442 \u0435\u043c\u0443 \u043f\u0430\u043a\u0435\u0442 \u2013 \u043d\u0430\u0437\u0430\u0434 \u0432 \u0441\u0442\u043e\u0440\u043e\u043d\u0443 R1.<\/p>\n<\/li>\n<\/ol>\n<p> \u041f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043f\u043e RFC 2328:<\/p>\n<ol>\n<li>\n<p> R1 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 ASBR1 \u0438\u0437 \u0434\u0440\u0443\u0433\u043e\u0439 \u0437\u043e\u043d\u044b \u0441 ASBR2 \u0432 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u0435 \u0438 \u0441\u0447\u0438\u0442\u0430\u0435\u0442 \u0438\u0445 \u0440\u0430\u0432\u043d\u043e\u0446\u0435\u043d\u043d\u044b\u043c\u0438.<\/p>\n<\/li>\n<li>\n<p>R1 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0434\u043e ASBR1 (2) \u0438 ASBR2 (13).<\/p>\n<\/li>\n<li>\n<p>ASBR1 \u0431\u043b\u0438\u0436\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 R1 \u043e\u0442\u043f\u0440\u0430\u0432\u043b\u044f\u0435\u0442 \u0435\u043c\u0443 \u043f\u0430\u043a\u0435\u0442 \u0447\u0435\u0440\u0435\u0437 ABR2.<\/p>\n<\/li>\n<\/ol>\n<p>\u041a\u043e\u0440\u0435\u043d\u044c \u0437\u043b\u0430 \u0432 \u043e\u043f\u0438\u0441\u0430\u043d\u043d\u044b\u0445 \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u044f\u0445 \u2013 \u043f\u043e\u043d\u0438\u0436\u0435\u043d\u0438\u0435 \u043f\u0440\u0438\u043e\u0440\u0438\u0442\u0435\u0442\u0430 ASBR \u043f\u043e \u043f\u0443\u0442\u0438 \u0441\u043b\u0435\u0434\u043e\u0432\u0430\u043d\u0438\u044f \u043f\u0430\u043a\u0435\u0442\u0430. RFC 2328 \u0438\u0441\u043a\u043b\u044e\u0447\u0430\u0435\u0442 \u0442\u0430\u043a\u0438\u0435 \u0441\u0438\u0442\u0443\u0430\u0446\u0438\u0438 \u0446\u0435\u043d\u043e\u0439 \u043d\u0435\u043e\u043f\u0442\u0438\u043c\u0430\u043b\u044c\u043d\u043e\u0439 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438. \u0410\u0432\u0442\u043e\u0440\u044b RFC \u043f\u043e\u0441\u0447\u0438\u0442\u0430\u043b\u0438, \u0447\u0442\u043e \u043d\u0435\u044d\u0444\u0444\u0435\u043a\u0442\u0438\u0432\u043d\u044b\u0439 \u043f\u0443\u0442\u044c \u043e\u0431\u044b\u0447\u043d\u043e \u043b\u0443\u0447\u0448\u0435 \u043e\u0442\u0441\u0443\u0442\u0441\u0442\u0432\u0443\u044e\u0449\u0435\u0433\u043e.<\/p>\n<p>OSPF \u2013 \u0434\u043e\u0441\u0442\u0430\u0442\u043e\u0447\u043d\u043e \u0441\u043b\u043e\u0436\u043d\u044b\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b \u0441 \u043e\u0433\u0440\u0430\u043d\u0438\u0447\u0435\u043d\u043d\u043e\u0439 \u0433\u0438\u0431\u043a\u043e\u0441\u0442\u044c\u044e. \u041a\u043e\u043d\u0435\u0447\u043d\u043e, \u0434\u043e \u043e\u043f\u0440\u0435\u0434\u0435\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u0442\u0435\u043f\u0435\u043d\u0438 \u0435\u0433\u043e \u043f\u043e\u0432\u0435\u0434\u0435\u043d\u0438\u0435 \u043c\u043e\u0436\u043d\u043e \u043e\u043f\u0442\u0438\u043c\u0438\u0437\u0438\u0440\u043e\u0432\u0430\u0442\u044c, \u043e\u0434\u043d\u0430\u043a\u043e \u043d\u0443\u0436\u043d\u043e \u043e\u0447\u0435\u043d\u044c \u0445\u043e\u0440\u043e\u0448\u043e \u043f\u043e\u043d\u0438\u043c\u0430\u0442\u044c \u043f\u043e\u0441\u043b\u0435\u0434\u0441\u0442\u0432\u0438\u044f, \u0447\u0442\u043e\u0431\u044b \u043d\u0435 \u043f\u043e\u043f\u0430\u0441\u0442\u044c \u0432\u043f\u0440\u043e\u0441\u0430\u043a. \u0412 \u0446\u0435\u043b\u043e\u043c, \u043f\u0440\u0438\u043d\u0446\u0438\u043f KISS \u043a\u0430\u043a \u043d\u0435\u043b\u044c\u0437\u044f \u043b\u0443\u0447\u0448\u0435 \u043f\u043e\u0434\u0445\u043e\u0434\u0438\u0442 \u043a OSPF. \u0415\u0441\u043b\u0438 \u0436\u0435 \u043d\u0435\u043e\u0431\u0445\u043e\u0434\u0438\u043c \u0431\u043e\u043b\u0435\u0435 \u0433\u0438\u0431\u043a\u0438\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b, \u0432\u044b\u0431\u043e\u0440 \u043e\u0447\u0435\u0432\u0438\u0434\u0435\u043d: \u0432\u0430\u043c \u043d\u0443\u0436\u0435\u043d \u0438\u043b\u0438 BGP, \u0438\u043b\u0438 \u0441\u0435\u0442\u0435\u0432\u043e\u0439 \u0430\u0440\u0445\u0438\u0442\u0435\u043a\u0442\u043e\u0440 \u043f\u043e\u043b\u0443\u0447\u0448\u0435.<\/p>\n<p>\u0421\u043f\u0430\u0441\u0438\u0431\u043e \u0437\u0430 \u0440\u0435\u0446\u0435\u043d\u0437\u0438\u044e: <strong>\u0410\u043d\u0430\u0441\u0442\u0430\u0441\u0438\u0438 \u041a\u0443\u0440\u0430\u043b\u0451\u0432\u043e\u0439<\/strong><\/p>\n<p>\u041a\u0430\u043d\u0430\u043b \u0432 \u0422\u0435\u043b\u0435\u0433\u0440\u0430\u043c\u0435: <a href=\"https:\/\/t.me\/networking_it_ru\" rel=\"noopener noreferrer nofollow\">https:\/\/t.me\/networking_it_ru<\/a><\/p>\n<\/p>\n<\/div>\n<\/div>\n<\/div>\n<p> <!----> <!----><\/div>\n<p> <!----> <!----><br \/> \u0441\u0441\u044b\u043b\u043a\u0430 \u043d\u0430 \u043e\u0440\u0438\u0433\u0438\u043d\u0430\u043b \u0441\u0442\u0430\u0442\u044c\u0438 <a href=\"https:\/\/habr.com\/ru\/post\/700384\/\"> https:\/\/habr.com\/ru\/post\/700384\/<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<div><\/div>\n<div id=\"post-content-body\">\n<div>\n<div class=\"article-formatted-body article-formatted-body article-formatted-body_version-2\">\n<div xmlns=\"http:\/\/www.w3.org\/1999\/xhtml\">\n<p>\u041d\u0435 \u0442\u0430\u043a \u0434\u0430\u0432\u043d\u043e \u044f \u0440\u0430\u0441\u0441\u043a\u0430\u0437\u0430\u043b \u043f\u0440\u043e <a href=\"https:\/\/habr.com\/ru\/post\/700380\/\" rel=\"noopener noreferrer nofollow\">\u043e\u0434\u043d\u0443 \u0438\u0437 \u043f\u0440\u0438\u0447\u0438\u043d<\/a> \u043f\u043e\u044f\u0432\u043b\u0435\u043d\u0438\u044f <a href=\"https:\/\/datatracker.ietf.org\/doc\/html\/rfc2328\" rel=\"noopener noreferrer nofollow\">RFC 2328<\/a> \u043d\u0430 \u0441\u043c\u0435\u043d\u0443 <a href=\"https:\/\/datatracker.ietf.org\/doc\/html\/rfc1583\" rel=\"noopener noreferrer nofollow\">RFC 1583<\/a>. \u0412\u043f\u0440\u043e\u0447\u0435\u043c, \u043e\u043f\u0438\u0441\u0430\u043d\u043d\u044b\u0439 \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0439 \u0432\u043e\u0437\u043d\u0438\u043a\u043d\u043e\u0432\u0435\u043d\u0438\u044f \u043f\u0435\u0442\u043b\u0438 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438 \u0441\u043e\u0432\u0441\u0435\u043c \u043d\u0435 \u0435\u0434\u0438\u043d\u0441\u0442\u0432\u0435\u043d\u043d\u044b\u0439. \u0422\u0435 \u0438\u0437 \u0432\u0430\u0441, \u043a\u0442\u043e \u043f\u043e\u0441\u043c\u043e\u0442\u0440\u0435\u043b \u043d\u0430 <a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2178#appendix-G.7\" rel=\"noopener noreferrer nofollow\">RFC 2178<\/a>, \u0441\u043a\u043e\u0440\u0435\u0435 \u0432\u0441\u0435\u0433\u043e, \u0443\u0436\u0435 \u0434\u043e\u0433\u0430\u0434\u044b\u0432\u0430\u044e\u0442\u0441\u044f, \u043e \u0447\u0435\u043c \u043f\u043e\u0439\u0434\u0451\u0442 \u0440\u0435\u0447\u044c \u0434\u0430\u043b\u044c\u0448\u0435.<\/p>\n<p>\u041f\u043e\u043c\u0438\u043c\u043e \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0430\u0433\u0440\u0435\u0433\u0438\u0440\u043e\u0432\u0430\u043d\u043d\u044b\u0445 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u043e\u0432, RFC 2328 \u0442\u0430\u043a\u0436\u0435 \u0438\u0437\u043c\u0435\u043d\u0438\u043b \u043f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430 \u0434\u043b\u044f \u0432\u043d\u0435\u0448\u043d\u0438\u0445 \u043f\u0440\u0435\u0444\u0438\u043a\u0441\u043e\u0432.<\/p>\n<blockquote>\n<p><em>Otherwise, compare the cost of this new AS external path to the ones present in the table.  Type 1 external paths are always shorter than type 2 external paths.  Type 1 external paths are compared by looking at the sum of the distance to the forwarding address and the advertised type 1 metric (X+Y).  Type 2 external paths are compared by looking at the  advertised type 2 metrics, and then if necessary, the distance to the forwarding addresses.<\/em><\/p>\n<p>RFC 1583, <a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc1583#page-154\" rel=\"noopener noreferrer nofollow\">section 16.4<\/a><\/p>\n<\/blockquote>\n<blockquote>\n<p><em>Compare the AS external path described by the LSA with the existing paths in N&#8217;s routing table entry, as follows. If the new path is preferred, it replaces the present paths in N&#8217;s routing table entry.  If the new path is of equal preference, it is added to N&#8217;s routing table entry&#8217;s list of paths.<\/em><\/p>\n<p><em>(a) Intra-area and inter-area paths are always preferred over AS external paths.<\/em><\/p>\n<p><em>(b) Type 1 external paths are always preferred over type 2 external paths. When all paths are type 2 external paths, the paths with the smallest advertised type 2 metric are always preferred.<\/em><\/p>\n<p><em>(c) If the new AS external path is still indistinguishable from the current paths in the N&#8217;s routing table entry, and RFC1583Compatibility is set to &#171;disabled&#187;, select the preferred paths based on the intra-AS paths to the ASBR\/forwarding addresses, as specified in Section 16.4.1.<\/em><\/p>\n<p><em>(d) If the new AS external path is still indistinguishable from the current paths in the N&#8217;s routing table entry, select the preferred path based on a least cost comparison.  Type 1 external paths are compared by looking at the sum of the distance to the forwarding address and the advertised type 1 metric (X+Y).  Type 2 external paths advertising equal type 2 metrics are compared by looking at the distance to the forwarding addresses.<\/em><\/p>\n<p><em>RFC 2328, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2328.html#page-174\" rel=\"noopener noreferrer nofollow\"><em>section 16.4<\/em><\/a><\/p>\n<\/blockquote>\n<blockquote>\n<p>1. <em>Intra-area paths using non-backbone areas are always the most preferred.<br \/>2. The other paths, intra-area backbone paths and inter-area paths, are of equal preference.<\/em><\/p>\n<p><em>RFC 2328, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2328.html#page-175\" rel=\"noopener noreferrer nofollow\"><em>section 16.4.1<\/em><\/a><\/p>\n<\/blockquote>\n<p>\u0412\u043c\u0435\u0441\u0442\u043e \u043f\u0440\u044f\u043c\u043e\u0433\u043e \u043f\u0435\u0440\u0435\u0432\u043e\u0434\u0430 \u044f \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0443 \u043e\u0431\u043e\u0431\u0449\u0438\u0442\u044c \u0441\u0443\u0442\u044c \u0440\u0430\u0437\u043b\u0438\u0447\u0438\u0439:  <\/p>\n<ol>\n<li>\n<p>RFC 1583 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u043e\u0434\u0438\u043d\u0430\u043a\u043e\u0432\u044b\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u044b \u043e\u0442 \u0440\u0430\u0437\u043d\u044b\u0445 ASBR \u0441\u0443\u0433\u0443\u0431\u043e \u043f\u043e \u043c\u0435\u0442\u0440\u0438\u043a\u0435.<\/p>\n<\/li>\n<li>\n<p>RFC 2328, \u0432 \u0441\u0432\u043e\u044e \u043e\u0447\u0435\u0440\u0435\u0434\u044c, \u043e\u0442\u0434\u0430\u0451\u0442 \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0435\u043d\u0438\u0435 ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0449\u0438\u043c\u0441\u044f \u0432\u043d\u0443\u0442\u0440\u0438 \u0442\u043e\u0439 \u0436\u0435 \u043d\u0435\u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b; \u0435\u0441\u043b\u0438 \u0441\u0434\u0435\u043b\u0430\u0442\u044c \u0432\u044b\u0431\u043e\u0440 \u0432\u0441\u0451 \u0435\u0449\u0451 \u043d\u0435 \u0443\u0434\u0430\u043b\u043e\u0441\u044c, \u0442\u043e\u0433\u0434\u0430 OSPF \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0434\u043e ASBR \u0442\u0430\u043a \u0436\u0435, \u043a\u0430\u043a \u0438 RFC 1583.<\/p>\n<\/li>\n<\/ol>\n<p>\u041f\u043e\u043b\u0443\u0447\u0430\u0435\u0442\u0441\u044f, \u0447\u0442\u043e \u043d\u0430\u0441 \u0438\u043d\u0442\u0435\u0440\u0435\u0441\u0443\u044e\u0442 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0438\u0435 \u044d\u043b\u0435\u043c\u0435\u043d\u0442\u044b \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430:<\/p>\n<ol>\n<li>\n<p>\u043f\u0440\u0438\u043e\u0440\u0438\u0442\u0435\u0442 ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0449\u0438\u0445\u0441\u044f \u0432 \u0442\u043e\u0439 \u0436\u0435 \u043d\u0435\u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u0435;<\/p>\n<\/li>\n<li>\n<p>\u0440\u0430\u0432\u0435\u043d\u0441\u0442\u0432\u043e ASBR, \u043d\u0430\u0445\u043e\u0434\u044f\u0448\u0438\u0445\u0441\u044f \u0432 \u0437\u043e\u043d\u0435 0, \u0438 ASBR \u0438\u0437 \u0434\u0440\u0443\u0433\u0438\u0445 \u0437\u043e\u043d.<\/p>\n<\/li>\n<\/ol>\n<p>\u0420\u0430\u0441\u0441\u043c\u043e\u0442\u0440\u0438\u043c \u043f\u0440\u043e\u0441\u0442\u043e\u0439 \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0439:<\/p>\n<figure class=\"full-width\"><figcaption><\/figcaption><\/figure>\n<p>ASBR \u043e\u0431\u043c\u0435\u043d\u0438\u0432\u0430\u044e\u0442\u0441\u044f \u043d\u0435\u0441\u043a\u043e\u043b\u044c\u043a\u0438\u043c\u0438 \u043f\u0440\u0435\u0444\u0438\u043a\u0441\u0430\u043c\u0438 \u0441 \u0443\u0437\u043b\u043e\u043c BGP: \u043f\u043e\u043b\u0443\u0447\u0430\u044e\u0442 1.1.1.1\/32 \u0438 \u0430\u043d\u043e\u043d\u0441\u0438\u0440\u0443\u044e\u0442 3.3.3.3\/32. \u041f\u043e\u043c\u0438\u043c\u043e \u044d\u0442\u043e\u0433\u043e, ASBR \u043e\u0431\u044a\u044f\u0432\u043b\u044f\u044e\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442 \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u0432 OSPF \u0434\u043e\u043c\u0435\u043d. \u0414\u0432\u0430 \u0441\u043e\u0435\u0434\u0438\u043d\u0435\u043d\u0438\u044f \u0438\u043c\u0435\u044e\u0442 \u043d\u0435\u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u043d\u044b\u0439 \u0432\u0435\u0441, \u0438\u0445 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u044f \u043e\u0442\u043c\u0435\u0447\u0435\u043d\u044b \u043a\u0440\u0430\u0441\u043d\u044b\u043c \u0446\u0432\u0435\u0442\u043e\u043c. \u041e\u0441\u0442\u0430\u043b\u044c\u043d\u0430\u044f \u043d\u0430\u0441\u0442\u0440\u043e\u0439\u043a\u0430 \u043d\u0435 \u043f\u0440\u0435\u0434\u0441\u0442\u0430\u0432\u043b\u044f\u0435\u0442 \u0441\u0443\u0449\u0435\u0441\u0442\u0432\u0435\u043d\u043d\u043e\u0433\u043e \u0438\u043d\u0442\u0435\u0440\u0435\u0441\u0430, \u0432\u0441\u0435 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u044f \u043e\u0441\u0442\u0430\u0432\u043b\u0435\u043d\u044b \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u2013 \u0442\u043e\u043b\u044c\u043a\u043e \u043b\u043e\u0432\u043a\u043e\u0441\u0442\u044c \u0440\u0443\u043a \u0438 \u043d\u0438\u043a\u0430\u043a\u043e\u0439 \u043c\u0430\u0433\u0438\u0438.<\/p>\n<pre><code>BGP#sho run | section interface|router interface Loopback0  ip address 1.1.1.1 255.255.255.255 interface FastEthernet0\/0  ip address 192.168.16.1 255.255.255.0 interface FastEthernet0\/1  ip address 192.168.12.1 255.255.255.0 router bgp 1  no bgp default ipv4-unicast  neighbor 192.168.12.2 remote-as 100  neighbor 192.168.16.6 remote-as 100  !  address-family ipv4   network 1.1.1.1 mask 255.255.255.255   neighbor 192.168.12.2 activate   neighbor 192.168.16.6 activate<\/code><\/pre>\n<pre><code>ASBR1#sho run | s interface|router interface Loopback0  ip address 2.2.2.2 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.23.2 255.255.255.0  ip ospf 1 area 0  ip ospf cost 10 interface FastEthernet0\/1  ip address 192.168.12.2 255.255.255.0 router ospf 1  default-information originate always router bgp 100  no bgp default ipv4-unicast  neighbor 192.168.12.1 remote-as 1  !  address-family ipv4   network 3.3.3.3 mask 255.255.255.255   neighbor 192.168.12.1 activate<\/code><\/pre>\n<pre><code>ASBR2#sho run | section interface|router interface Loopback0  ip address 6.6.6.6 255.255.255.255  ip ospf 1 area 1 interface FastEthernet0\/0  ip address 192.168.16.6 255.255.255.0 interface FastEthernet0\/1  ip address 192.168.56.6 255.255.255.0  ip ospf 1 area 1 interface FastEthernet1\/0  ip address 192.168.46.6 255.255.255.0  ip ospf 1 area 1  ip ospf cost 100 router ospf 1  default-information originate always router bgp 100  no bgp default ipv4-unicast  neighbor 192.168.16.1 remote-as 1  !  address-family ipv4   network 3.3.3.3 mask 255.255.255.255   neighbor 192.168.16.1 activate<\/code><\/pre>\n<pre><code>ABR1#sho run | section interface|router interface Loopback0  ip address 4.4.4.4 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.45.4 255.255.255.0  ip ospf 1 area 0 interface FastEthernet0\/1  ip address 192.168.34.4 255.255.255.0  ip ospf 1 area 0 interface FastEthernet1\/0  ip address 192.168.46.4 255.255.255.0  ip ospf 1 area 1  ip ospf cost 100 router ospf 1<\/code><\/pre>\n<pre><code>ABR2#sho run | section interface|router interface Loopback0  ip address 5.5.5.5 255.255.255.255  ip ospf 1 area 0 interface FastEthernet0\/0  ip address 192.168.45.5 255.255.255.0  ip ospf 1 area 0 interface FastEthernet0\/1  ip address 192.168.56.5 255.255.255.0  ip ospf 1 area 1 router ospf 1<\/code><\/pre>\n<pre><code>R#sho run | section interface|router interface Loopback0  ip address 3.3.3.3 255.255.255.255 interface FastEthernet0\/0  ip address 192.168.23.3 255.255.255.0  ip ospf cost 10 interface FastEthernet0\/1  ip address 192.168.34.3 255.255.255.0 router ospf 1  network 0.0.0.0 255.255.255.255 area 0<\/code><\/pre>\n<p>\u041c\u043e\u0436\u0435\u0442 \u043f\u043e\u043a\u0430\u0437\u0430\u0442\u044c\u0441\u044f, \u0447\u0442\u043e \u043f\u0440\u0438 \u0442\u0430\u043a\u043e\u0439 \u043d\u0435\u0432\u0438\u043d\u043d\u043e\u0439 \u043d\u0430\u0441\u0442\u0440\u043e\u0439\u043a\u0435 \u0443\u0437\u0435\u043b BGP \u0434\u043e\u043b\u0436\u0435\u043d \u0438\u043c\u0435\u0442\u044c \u0441\u0432\u044f\u0437\u043d\u043e\u0441\u0442\u044c \u0434\u043e 3.3.3.3\/32, \u0443\u0441\u0442\u0430\u043d\u0430\u0432\u043b\u0438\u0432\u0430\u044f \u0441\u043e\u0435\u0434\u0438\u043d\u0435\u043d\u0438\u0435 \u0441 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u043d\u0438\u0435\u043c 1.1.1.1\/32 \u0432 \u043a\u0430\u0447\u0435\u0441\u0442\u0432\u0430 \u0430\u0434\u0440\u0435\u0441\u0430 \u0438\u0441\u0442\u043e\u0447\u043d\u0438\u043a\u0430.<\/p>\n<pre><code>BGP#ping 3.3.3.3 so lo 0 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: Packet sent with a source address of 1.1.1.1  ..... Success rate is 0 percent (0\/5)<\/code><\/pre>\n<p>\u0427\u0442\u043e, \u0432\u043f\u0440\u043e\u0447\u0435\u043c, \u0441\u043e\u0432\u0435\u0440\u0448\u0435\u043d\u043d\u043e \u043d\u0435 \u043c\u0435\u0448\u0430\u0435\u0442 \u0441\u0435\u0442\u0438 \u0434\u043e\u0431\u0440\u043e\u0441\u043e\u0432\u0435\u0441\u0442\u043d\u043e \u0442\u0435\u0440\u044f\u0442\u044c \u0442\u0440\u0430\u0444\u0438\u043a. \u041c\u043e\u0436\u0435\u0442 \u0431\u044b\u0442\u044c, \u0433\u0434\u0435-\u0442\u043e \u043f\u043e \u043f\u0443\u0442\u0438 \u043d\u0435 \u0445\u0432\u0430\u0442\u0430\u0435\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u043e\u0432?<\/p>\n<pre><code>BGP#traceroute 3.3.3.3 source 1.1.1.1 Type escape sequence to abort. Tracing the route to 3.3.3.3 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.16.6 12 msec 24 msec 20 msec   2 192.168.56.5 56 msec 16 msec 36 msec   3  *  *  *  &lt;output omitted><\/code><\/pre>\n<p>\u041f\u043e\u0445\u043e\u0436\u0435 \u043d\u0430 \u0442\u043e, \u0447\u0442\u043e ABR1 \u043e\u0442\u0431\u0440\u0430\u0441\u044b\u0432\u0430\u0435\u0442 \u043f\u0440\u0438\u0445\u043e\u0434\u044f\u0449\u0438\u0435 \u043a \u043d\u0435\u043c\u0443 \u043f\u0430\u043a\u0435\u0442\u044b. \u041e\u0434\u043d\u0430\u043a\u043e \u043f\u0435\u0440\u0432\u043e\u0435 \u0432\u043f\u0435\u0447\u0430\u0442\u043b\u0435\u043d\u0438\u0435 \u043e\u0431\u043c\u0430\u043d\u0447\u0438\u0432\u043e, \u043e\u0441\u043e\u0431\u0435\u043d\u043d\u043e \u0435\u0441\u043b\u0438 \u0437\u0430\u043f\u0443\u0441\u0442\u0438\u0442\u044c traceroute \u0441 \u0434\u0440\u0443\u0433\u043e\u0439 \u0441\u0442\u043e\u0440\u043e\u043d\u044b:<\/p>\n<pre><code>R#traceroute 1.1.1.1 source 3.3.3.3 Type escape sequence to abort. Tracing the route to 1.1.1.1 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.34.4 16 msec 16 msec 20 msec   2 192.168.34.3 20 msec 24 msec 16 msec   3 192.168.34.4 32 msec 36 msec 40 msec   4 192.168.34.3 36 msec 40 msec 36 msec &lt;\u043d\u0443 \u0432\u044b \u043f\u043e\u043d\u044f\u043b\u0438><\/code><\/pre>\n<figure class=\"full-width\"><figcaption><\/figcaption><\/figure>\n<p>\u0415\u0441\u043b\u0438 \u043f\u043e\u0441\u043c\u043e\u0442\u0440\u0435\u0442\u044c \u043d\u0430 \u0441\u0445\u0435\u043c\u0443, \u0442\u043e \u0432\u044b\u0431\u043e\u0440 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430 \u043f\u043e \u0443\u043c\u043e\u043b\u0447\u0430\u043d\u0438\u044e \u0432 \u0441\u0442\u043e\u0440\u043e\u043d\u0443 ASBR2 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u043e\u043c R \u0432\u044b\u0433\u043b\u044f\u0434\u0438\u0442 \u0440\u0430\u0437\u0443\u043c\u043d\u044b\u043c:  <\/p>\n<pre><code>R#sho ip ospf border-routers                  OSPF Router with ID (3.3.3.3) (Process ID 1)   Base Topology (MTID 0)  Internal Router Routing Table Codes: i - Intra-area route, I - Inter-area route  i 4.4.4.4 [1] via 192.168.34.4, FastEthernet0\/1, ABR, Area 0, SPF 12 i 5.5.5.5 [2] via 192.168.34.4, FastEthernet0\/1, ABR, Area 0, SPF 12 i 2.2.2.2 [10] via 192.168.23.2, FastEthernet0\/0, ASBR, Area 0, SPF 12 I 6.6.6.6 [3] via 192.168.34.4, FastEthernet0\/1, ASBR, Area 0, SPF 12 I 6.6.6.6 [101] via 192.168.34.4, FastEthernet0\/1, ASBR, Area 0, SPF 12<\/code><\/pre>\n<p>\u0410 \u0432\u043e\u0442 ABR1 \u0432\u0435\u0434\u0451\u0442 \u0441\u0435\u0431\u044f \u043d\u0435\u0441\u043a\u043e\u043b\u044c\u043a\u043e \u0441\u0442\u0440\u0430\u043d\u043d\u043e, \u043f\u043e \u043a\u0440\u0430\u0439\u043d\u0435\u0439 \u043c\u0435\u0440\u0435 \u043d\u0430 \u043f\u0435\u0440\u0432\u044b\u0439 \u0432\u0437\u0433\u043b\u044f\u0434:<\/p>\n<pre><code>ABR1#sho ip ospf border-routers               OSPF Router with ID (4.4.4.4) (Process ID 1)   Base Topology (MTID 0)  Internal Router Routing Table Codes: i - Intra-area route, I - Inter-area route  i 5.5.5.5 [101] via 192.168.46.6, FastEthernet1\/0, ABR, Area 1, SPF 8 i 5.5.5.5 [1] via 192.168.45.5, FastEthernet0\/0, ABR, Area 0, SPF 9 i 2.2.2.2 [11] via 192.168.34.3, FastEthernet0\/1, ASBR, Area 0, SPF 9 i 6.6.6.6 [100] via 192.168.46.6, FastEthernet1\/0, ASBR, Area 1, SPF 8<\/code><\/pre>\n<p>\u041e\u0431\u0440\u0430\u0442\u0438\u0442\u0435 \u043f\u0440\u0438\u0441\u0442\u0430\u043b\u044c\u043d\u043e\u0435 \u0432\u043d\u0438\u043c\u0430\u043d\u0438\u0435 \u043d\u0430 \u0437\u043d\u0430\u0447\u0435\u043d\u0438\u0435 \u043c\u0435\u0442\u0440\u0438\u043a\u0438 \u0434\u043e ASBR2 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u043e\u0431\u043e\u0438\u0445 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u043e\u0432. R \u0432\u044b\u0431\u0438\u0440\u0430\u0435\u0442 \u043f\u0443\u0442\u044c \u0447\u0435\u0440\u0435\u0437 ABR2 \u0441 \u0432\u0435\u0441\u043e\u043c, \u0440\u0430\u0432\u043d\u044b\u043c 3; \u0432 \u0441\u0432\u043e\u044e \u043e\u0447\u0435\u0440\u0435\u0434\u044c, ABR1 \u043d\u0435 \u0438\u043c\u0435\u0435\u0442 \u043d\u0438 \u043c\u0430\u043b\u0435\u0439\u0448\u0435\u0433\u043e \u043f\u0440\u0435\u0434\u0441\u0442\u0430\u0432\u043b\u0435\u043d\u0438\u044f \u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0435 \u0447\u0435\u0440\u0435\u0437 ABR2 \u0438 \u0432\u0438\u0434\u0438\u0442 \u0442\u043e\u043b\u044c\u043a\u043e \u043f\u0443\u0442\u044c \u0441 \u0432\u0435\u0441\u043e\u043c, \u0440\u0430\u0432\u043d\u044b\u043c 101. \u041f\u0440\u0438\u0447\u0438\u043d\u0430 \u0442\u0430\u043a\u043e\u0433\u043e \u043f\u043e\u0432\u0435\u0434\u0435\u043d\u0438\u044f \u043f\u0440\u043e\u0437\u0430\u0438\u0447\u043d\u0430: ASBR2 \u0438 ABR1 \u043d\u0430\u0445\u043e\u0434\u044f\u0442\u0441\u044f \u0432 \u043e\u0434\u043d\u043e\u0439 \u0437\u043e\u043d\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 ABR1 \u043e\u0431\u044f\u0437\u0430\u043d \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u0442\u044c \u0432\u043d\u0443\u0442\u0440\u0438\u0437\u043e\u043d\u0430\u043b\u044c\u043d\u044b\u0439 \u043c\u0430\u0440\u0448\u0440\u0443\u0442. \u041a\u0430\u043a \u0441\u043b\u0435\u0434\u0441\u0442\u0432\u0438\u0435, \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0438\u0442\u0435\u043b\u044c\u043d\u043e\u0441\u0442\u044c ASBR \u0432 \u043e\u0447\u0435\u0440\u0435\u0434\u043d\u043e\u0439 \u0440\u0430\u0437 \u043c\u0435\u043d\u044f\u0435\u0442\u0441\u044f \u043f\u043e \u043f\u0443\u0442\u0438 \u0441\u043b\u0435\u0434\u043e\u0432\u0430\u043d\u0438\u044f \u043f\u0430\u043a\u0435\u0442\u0430, \u0447\u0442\u043e \u0438 \u043f\u0440\u0438\u0432\u043e\u0434\u0438\u0442 \u043a \u043f\u0435\u0442\u043b\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u0438.<\/p>\n<p>\u041f\u0435\u0440\u0435\u043a\u043b\u044e\u0447\u0438\u043c \u0432\u0441\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0442\u043e\u0440\u044b \u0434\u043e\u043c\u0435\u043d\u0430 \u0432 \u0440\u0435\u0436\u0438\u043c \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0441 RFC 2328:<\/p>\n<pre><code>R(config)#router ospf 1 R(config-router)#no compatible rfc1583<\/code><\/pre>\n<pre><code>R#traceroute 1.1.1.1 so 3.3.3.3 Type escape sequence to abort. Tracing the route to 1.1.1.1 VRF info: (vrf in name\/id, vrf out name\/id)   1 192.168.34.4 20 msec 32 msec 12 msec   2 192.168.46.6 12 msec 20 msec 8 msec   3 192.168.16.1 4 msec 28 msec 16 msec<\/code><\/pre>\n<pre><code>ABR1#sho ip ro os                               &lt;output omitted> Gateway of last resort is 192.168.46.6 to network 0.0.0.0  O*E2  0.0.0.0\/0 [110\/1] via 192.168.46.6, 00:02:00, FastEthernet0\/1 &lt;output omitted><\/code><\/pre>\n<p>\u041d\u0435\u0441\u043c\u043e\u0442\u0440\u044f \u043d\u0430 \u0442\u043e, \u0447\u0442\u043e \u043d\u0430\u043c \u0443\u0434\u0430\u043b\u043e\u0441\u044c \u043f\u043e\u0431\u043e\u0440\u043e\u0442\u044c \u043f\u0435\u0442\u043b\u044e, \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0438\u0437\u0430\u0446\u0438\u044f \u0441\u0442\u0430\u043b\u0430 \u043d\u0435\u043e\u043f\u0442\u0438\u043c\u0430\u043b\u044c\u043d\u043e\u0439. R \u0441\u0447\u0438\u0442\u0430\u0435\u0442 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u044b \u0434\u043e ASBR1 (\u0432\u043d\u0443\u0442\u0440\u0438 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b) \u0438 ASBR2 (\u043c\u0435\u0436\u0437\u043e\u043d\u0430\u043b\u044c\u043d\u044b\u0439) \u0440\u0430\u0432\u043d\u043e\u0446\u0435\u043d\u043d\u044b\u043c\u0438, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 \u0441\u0440\u0430\u0432\u043d\u0438\u0432\u0430\u0435\u0442 \u0438\u0445 \u0442\u043e\u043b\u044c\u043a\u043e \u043f\u043e \u043c\u0435\u0442\u0440\u0438\u043a\u0435. \u041d\u0435 \u043b\u0443\u0447\u0448\u0435 \u043b\u0438 \u0431\u044b\u043b\u043e \u043e\u0442\u0434\u0430\u0442\u044c \u043f\u0440\u0435\u0434\u043f\u043e\u0447\u0442\u0435\u043d\u0438\u0435 \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0443 \u0432\u043d\u0443\u0442\u0440\u0438 \u043e\u043f\u043e\u0440\u043d\u043e\u0439 \u0437\u043e\u043d\u044b? \u0418\u043c\u0435\u043d\u043d\u043e \u0442\u0430\u043a \u0438 \u0434\u0443\u043c\u0430\u043b\u0438 \u0430\u0432\u0442\u043e\u0440\u044b RFC 2178:<\/p>\n<blockquote>\n<p><em>1. Intra-area paths using non-backbone areas are always the most preferred.<br \/>2. Otherwise, intra-area backbone paths are preferred.<br \/>3. Inter-area paths are the least preferred.<\/em><\/p>\n<p><em>RFC 2178, <\/em><a href=\"https:\/\/www.rfc-editor.org\/rfc\/rfc2178.html#section-16.4.1\" rel=\"noopener noreferrer nofollow\"><em>section 16.4.1<\/em><\/a><\/p>\n<\/blockquote>\n<p>\u0412\u043f\u0440\u043e\u0447\u0435\u043c, \u043d\u0430\u0448\u043b\u0430\u0441\u044c \u0432\u0435\u0441\u043e\u043c\u0430\u044f \u043f\u0440\u0438\u0447\u0438\u043d\u0430 \u0438\u0441\u043f\u043e\u043b\u044c\u0437\u043e\u0432\u0430\u0442\u044c \u0442\u0435\u043a\u0443\u0449\u0438\u0439 \u043f\u0440\u043e\u0446\u0435\u0441\u0441 \u0432\u044b\u0431\u043e\u0440\u0430 \u043b\u0443\u0447\u0448\u0435\u0433\u043e \u043c\u0430\u0440\u0448\u0440\u0443\u0442\u0430:<\/p>\n<blockquote>\n<p><em>There is still the possibility of a<\/em><\/p>\n<\/blockquote>\n<\/div>\n<\/div>\n<\/div>\n<\/div>\n","protected":false},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[],"tags":[],"class_list":["post-343058","post","type-post","status-publish","format-standard","hentry"],"_links":{"self":[{"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=\/wp\/v2\/posts\/343058","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=%2Fwp%2Fv2%2Fcomments&post=343058"}],"version-history":[{"count":0,"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=\/wp\/v2\/posts\/343058\/revisions"}],"wp:attachment":[{"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=%2Fwp%2Fv2%2Fmedia&parent=343058"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=%2Fwp%2Fv2%2Fcategories&post=343058"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/savepearlharbor.com\/index.php?rest_route=%2Fwp%2Fv2%2Ftags&post=343058"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}